const regex = /(?:(?:0[1-9])|(?:[12][0-9])|(?:3[01])|[1-9])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:0[1-9])|(?:[12][0-9])|(?:3[01])|[1-9])', '')
const str = `29-02-2016 00:00:46.676 [qtp1746080167-2900285] [ERROR] DefaultDao - Error executing query.
java.lang.Exception: Update count not satisfied.
at com.til.etwealth.etmoney.db.entity.query.sql.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}