import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:0[1-9])|(?:[12][0-9])|(?:3[01])|[1-9])";
final String string = "29-02-2016 00:00:46.676 [qtp1746080167-2900285] [ERROR] DefaultDao - Error executing query.\n"
+ "java.lang.Exception: Update count not satisfied.\n"
+ " at com.til.etwealth.etmoney.db.entity.query.sql.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}