re = /\[(\d+\/\d+\/\d+),\s+(\d+:\d+:\d+\s+[a|p]m)\]\s(\w.+):\s(.+)/m
str = '[6/8/18, 7:40:41 pm] Kanu Tandon: Oye hoye! DP to Dekho zara'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end