package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(\d+\/\d+\/\d+),\s+(\d+:\d+:\d+\s+[a|p]m)\]\s(\w.+):\s(.+)`)
var str = `[6/8/18, 7:40:41 pm] Kanu Tandon: Oye hoye! DP to Dekho zara`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}