$re = '/\[(\d+\/\d+\/\d+),\s+(\d+:\d+:\d+\s+[a|p]m)\]\s(\w.+):\s(.+)/m';
$str = '[6/8/18, 7:40:41 pm] Kanu Tandon: Oye hoye! DP to Dekho zara';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);