const regex = new RegExp('[ab]b(?=([ab]))', 'gm')
const str = `.abbba
#at_most 2 blue block surrounded_by blue
# Gives True because there are 2 matches
# Should be False`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}