using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ab]b(?=([ab]))";
string input = @".abbba
#at_most 2 blue block surrounded_by blue
# Gives True because there are 2 matches
# Should be False";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}