#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[ab]b(?=([ab]))"
Local $sString = ".abbba" & @CRLF & _
"" & @CRLF & _
"#at_most 2 blue block surrounded_by blue" & @CRLF & _
"# Gives True because there are 2 matches" & @CRLF & _
"# Should be False"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")