re = /(<[a-z]*( *[a-z]*=[^<>]* *)*>)[^<>]*(<\/[a-z]*>)?/m
str = '<yay style="awesome:amazing;" >yay</yay>
<li> hi
<li> awesome'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end