package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<[a-z]*( *[a-z]*=[^<>]* *)*>)[^<>]*(<\/[a-z]*>)?`)
var str = `<yay style="awesome:amazing;" >yay</yay>
<li> hi
<li> awesome`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}