using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[a-z]*( *[a-z]*=[^<>]* *)*>)[^<>]*(<\/[a-z]*>)?";
string input = @"<yay style=""awesome:amazing;"" >yay</yay>
<li> hi
<li> awesome";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}