re = /\b(\w+)\b\s+\1\b/m
str = 'Test Test für den Regex Test. er findet keinen einen Treffer in diesem Satz tzt u u. bla bla bla bla blabla bla bla blabla. 1 1 1 2 2 .. . . .'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end