$re = '/\b(\w+)\b\s+\1\b/m';
$str = 'Test Test für den Regex Test. er findet keinen einen Treffer in diesem Satz tzt u u. bla bla bla bla blabla bla bla blabla. 1 1 1 2 2 .. . . .';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);