using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)\b\s+\1\b";
string input = @"Test Test für den Regex Test. er findet keinen einen Treffer in diesem Satz tzt u u. bla bla bla bla blabla bla bla blabla. 1 1 1 2 2 .. . . .";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}