re = /^(`{3}.*[\n\r][^]*?^`{3})/m
str = '```javascript
const foo = function(){
console.log(\'hello\')
}
```'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end