package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(`{3}.*[\n\r][^]*?^`{3})`)
var str = `\`\`\`javascript
const foo = function(){
console.log('hello')
}
\`\`\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}