$re = '/^(`{3}.*[\n\r][^]*?^`{3})/m';
$str = '```javascript
const foo = function(){
console.log(\'hello\')
}
```';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);