const regex = /\b(?:https?:\/\/)(?:www\d?\.)?[-\w\d&#%?\/=\.+]+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:https?:\\\/\\\/)(?:www\\d?\\.)?[-\\w\\d&#%?\\\/=\\.+]+\\b', 'gm')
const str = `HEN 1 ELSE 0 END AS CONNECT_BY_ISBRANCH
, CASE WHEN t.id IN (SELECT parent_id FROM tbl) THEN 0 ELSE 1 END AS CONNECT_BY_ISLEAF
, CASE WHEN th.SYS_CONNECT_BY_PATH_id LIKE '%/' + CAST(t.id AS VARCHAR(MAX)) + '/%'
THEN 1 ELSE 0 END AS CONNECT_BY_ISCYCLE
, th.SYS_CONNECT_BY_PATH_id + CAST(t.id AS VARCHAR(MAX)) + '/' AS SYS_CONNECT_BY_PATH_id
, th.SYS_CONNECT_BY_PATH_name + CAST(t.name AS VARCHAR(MAX)) + '/' AS SYS_CONNECT_BY_PATH_name
, th.root_id
, t.*
FROM tbl t
JOIN tbl_hierarchy th ON (th.id = t.parent_id) -- CONNECT BY PRIOR id = parent_id
WHERE th.CONNECT_BY_ISCYCLE = 0) -- NOCYCLE
SELECT th.*
--, REPLICATE(' ', (th."LEVEL" - 1) * 3) + th.name AS tbl_hierarchy
FROM tbl_hierarchy th
JOIN tbl CONNECT_BY_ROOT ON (CONNECT_BY_ROOT.id = th.root_id)
ORDER BY th.SYS_CONNECT_BY_PATH_name; -- ORDER SIBLINGS BY name
هذا شرح لميزات CONNECT BY الموضّحة أعلاه:
https://academy.hsoub.com/programming/sql/%D8%A7%D9%84%D8%AA%D8%B9%D8%A7%D8%A8%D9%8A%D8%B1-%D8%A7%D9%84%D8%AC%D8%AF%D9%88%D9%84%D9%8A%D8%A9-%D8%A7%D9%84%D8%B4%D8%A7%D8%A6%D8%B9%D8%A9-common-table-expressions-%D9%81%D9%8A-sql-r856/
and http://www.watheq.xyz/ and https://twitter.com/home
العبارات
CONNECT BY: تحدّد العلاقة التي تعرّف التشعّب
START WITH: تحدّد العقدة الجذرية (root nodes).
ORDER SIBLINGS BY: تحدّد ترتيب النتائج
المعاملات
NOCYCLE: توقِف معالجة فرع معيّن عند رصد شعبة دورية (loop). لأنّ الشعب الصالحة هي الشعب غير الدورية (Directed Acyclic)، أي الشعب التي لا يمكن العودة عبرها إلى العقدة نفسها.
العمليات
PRIOR: تحصل على البيانات من العقدة الأب (node's parent).
CONNECT_BY_ROOT: تحصل على البيانات من العقدة الجذرية.
أشباه الأعمدة Pseudocolumns
LEVEL: تشير إلى مسافة العقدة من جذرها.
CONNECT_BY_ISLEAF: تشير إلى عقدة بدون فروعها.
CONNECT_BY_ISCYCLE: تشير إلى عقدة ذات مرجع دائري (circular reference).
الدوال
SYS_CONNECT_BY_PATH: تعيد سلسلة نصية تمثّل المسار من الجذر إلى العقدة.
ترجمة -وبتصرّف- للفصل 46 من الكتاب SQL Notes for Professionals`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}