#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:https?:\/\/)(?:www\d?\.)?[-\w\d&#%?\/=\.+]+\b"
Local $sString = "HEN 1 ELSE 0 END AS CONNECT_BY_ISBRANCH" & @CRLF & _
" , CASE WHEN t.id IN (SELECT parent_id FROM tbl) THEN 0 ELSE 1 END AS CONNECT_BY_ISLEAF" & @CRLF & _
" , CASE WHEN th.SYS_CONNECT_BY_PATH_id LIKE '%/' + CAST(t.id AS VARCHAR(MAX)) + '/%'" & @CRLF & _
" THEN 1 ELSE 0 END AS CONNECT_BY_ISCYCLE" & @CRLF & _
" , th.SYS_CONNECT_BY_PATH_id + CAST(t.id AS VARCHAR(MAX)) + '/' AS SYS_CONNECT_BY_PATH_id" & @CRLF & _
" , th.SYS_CONNECT_BY_PATH_name + CAST(t.name AS VARCHAR(MAX)) + '/' AS SYS_CONNECT_BY_PATH_name" & @CRLF & _
" , th.root_id" & @CRLF & _
" , t.*" & @CRLF & _
" FROM tbl t" & @CRLF & _
" JOIN tbl_hierarchy th ON (th.id = t.parent_id) -- CONNECT BY PRIOR id = parent_id" & @CRLF & _
" WHERE th.CONNECT_BY_ISCYCLE = 0) -- NOCYCLE" & @CRLF & _
"SELECT th.*" & @CRLF & _
" --, REPLICATE(' ', (th."LEVEL" - 1) * 3) + th.name AS tbl_hierarchy" & @CRLF & _
" FROM tbl_hierarchy th" & @CRLF & _
" JOIN tbl CONNECT_BY_ROOT ON (CONNECT_BY_ROOT.id = th.root_id)" & @CRLF & _
" ORDER BY th.SYS_CONNECT_BY_PATH_name; -- ORDER SIBLINGS BY name" & @CRLF & _
"هذا شرح لميزات CONNECT BY الموضّحة أعلاه:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://academy.hsoub.com/programming/sql/%D8%A7%D9%84%D8%AA%D8%B9%D8%A7%D8%A8%D9%8A%D8%B1-%D8%A7%D9%84%D8%AC%D8%AF%D9%88%D9%84%D9%8A%D8%A9-%D8%A7%D9%84%D8%B4%D8%A7%D8%A6%D8%B9%D8%A9-common-table-expressions-%D9%81%D9%8A-sql-r856/" & @CRLF & _
"" & @CRLF & _
"and http://www.watheq.xyz/ and https://twitter.com/home" & @CRLF & _
" " & @CRLF & _
"العبارات" & @CRLF & _
"CONNECT BY: تحدّد العلاقة التي تعرّف التشعّب" & @CRLF & _
"START WITH: تحدّد العقدة الجذرية (root nodes)." & @CRLF & _
"ORDER SIBLINGS BY: تحدّد ترتيب النتائج" & @CRLF & _
"المعاملات" & @CRLF & _
"NOCYCLE: توقِف معالجة فرع معيّن عند رصد شعبة دورية (loop). لأنّ الشعب الصالحة هي الشعب غير الدورية (Directed Acyclic)، أي الشعب التي لا يمكن العودة عبرها إلى العقدة نفسها." & @CRLF & _
"العمليات" & @CRLF & _
"PRIOR: تحصل على البيانات من العقدة الأب (node's parent)." & @CRLF & _
"CONNECT_BY_ROOT: تحصل على البيانات من العقدة الجذرية." & @CRLF & _
"أشباه الأعمدة Pseudocolumns" & @CRLF & _
"LEVEL: تشير إلى مسافة العقدة من جذرها." & @CRLF & _
"CONNECT_BY_ISLEAF: تشير إلى عقدة بدون فروعها." & @CRLF & _
"CONNECT_BY_ISCYCLE: تشير إلى عقدة ذات مرجع دائري (circular reference)." & @CRLF & _
"الدوال" & @CRLF & _
"SYS_CONNECT_BY_PATH: تعيد سلسلة نصية تمثّل المسار من الجذر إلى العقدة." & @CRLF & _
"ترجمة -وبتصرّف- للفصل 46 من الكتاب SQL Notes for Professionals"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")