import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:https?:\\/\\/)(?:www\\d?\\.)?[-\\w\\d&#%?\\/=\\.+]+\\b";
final String string = "HEN 1 ELSE 0 END AS CONNECT_BY_ISBRANCH\n"
+ " , CASE WHEN t.id IN (SELECT parent_id FROM tbl) THEN 0 ELSE 1 END AS CONNECT_BY_ISLEAF\n"
+ " , CASE WHEN th.SYS_CONNECT_BY_PATH_id LIKE '%/' + CAST(t.id AS VARCHAR(MAX)) + '/%'\n"
+ " THEN 1 ELSE 0 END AS CONNECT_BY_ISCYCLE\n"
+ " , th.SYS_CONNECT_BY_PATH_id + CAST(t.id AS VARCHAR(MAX)) + '/' AS SYS_CONNECT_BY_PATH_id\n"
+ " , th.SYS_CONNECT_BY_PATH_name + CAST(t.name AS VARCHAR(MAX)) + '/' AS SYS_CONNECT_BY_PATH_name\n"
+ " , th.root_id\n"
+ " , t.*\n"
+ " FROM tbl t\n"
+ " JOIN tbl_hierarchy th ON (th.id = t.parent_id) -- CONNECT BY PRIOR id = parent_id\n"
+ " WHERE th.CONNECT_BY_ISCYCLE = 0) -- NOCYCLE\n"
+ "SELECT th.*\n"
+ " --, REPLICATE(' ', (th.\"LEVEL\" - 1) * 3) + th.name AS tbl_hierarchy\n"
+ " FROM tbl_hierarchy th\n"
+ " JOIN tbl CONNECT_BY_ROOT ON (CONNECT_BY_ROOT.id = th.root_id)\n"
+ " ORDER BY th.SYS_CONNECT_BY_PATH_name; -- ORDER SIBLINGS BY name\n"
+ "هذا شرح لميزات CONNECT BY الموضّحة أعلاه:\n\n\n"
+ "https://academy.hsoub.com/programming/sql/%D8%A7%D9%84%D8%AA%D8%B9%D8%A7%D8%A8%D9%8A%D8%B1-%D8%A7%D9%84%D8%AC%D8%AF%D9%88%D9%84%D9%8A%D8%A9-%D8%A7%D9%84%D8%B4%D8%A7%D8%A6%D8%B9%D8%A9-common-table-expressions-%D9%81%D9%8A-sql-r856/\n\n"
+ "and http://www.watheq.xyz/ and https://twitter.com/home\n"
+ " \n"
+ "العبارات\n"
+ "CONNECT BY: تحدّد العلاقة التي تعرّف التشعّب\n"
+ "START WITH: تحدّد العقدة الجذرية (root nodes).\n"
+ "ORDER SIBLINGS BY: تحدّد ترتيب النتائج\n"
+ "المعاملات\n"
+ "NOCYCLE: توقِف معالجة فرع معيّن عند رصد شعبة دورية (loop). لأنّ الشعب الصالحة هي الشعب غير الدورية (Directed Acyclic)، أي الشعب التي لا يمكن العودة عبرها إلى العقدة نفسها.\n"
+ "العمليات\n"
+ "PRIOR: تحصل على البيانات من العقدة الأب (node's parent).\n"
+ "CONNECT_BY_ROOT: تحصل على البيانات من العقدة الجذرية.\n"
+ "أشباه الأعمدة Pseudocolumns\n"
+ "LEVEL: تشير إلى مسافة العقدة من جذرها.\n"
+ "CONNECT_BY_ISLEAF: تشير إلى عقدة بدون فروعها.\n"
+ "CONNECT_BY_ISCYCLE: تشير إلى عقدة ذات مرجع دائري (circular reference).\n"
+ "الدوال\n"
+ "SYS_CONNECT_BY_PATH: تعيد سلسلة نصية تمثّل المسار من الجذر إلى العقدة.\n"
+ "ترجمة -وبتصرّف- للفصل 46 من الكتاب SQL Notes for Professionals";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}