re = /<\w+>.*?<\/\w+>/m
str = '[\'<body>Welcome to our course! It would be an awesome experience</body>\',
\'<article>To be a data scientist, you need to have knowledge in statistics and mathematics</article>\',
\'<nav>About me Links Contact me!\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end