#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\w+>.*?<\/\w+>"
Local $sString = "['<body>Welcome to our course! It would be an awesome experience</body>'," & @CRLF & _
" '<article>To be a data scientist, you need to have knowledge in statistics and mathematics</article>'," & @CRLF & _
" '<nav>About me Links Contact me!']"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")