package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\w+>.*?<\/\w+>`)
var str = `['<body>Welcome to our course! It would be an awesome experience</body>',
'<article>To be a data scientist, you need to have knowledge in statistics and mathematics</article>',
'<nav>About me Links Contact me!']`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}