import Foundation
let pattern = #"\b(support post-livraison|support post livraison|support client post livraison|support client post-livraison|post-livraison|post livraison|support client|support post|client post-livraison|client post livraison|support|livraison)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
//1. support post-livraison
//2. support post livraison
//3. support client post livraison
//4. support client post-livraison
//5. post-livraison
//6. post livraison
//7. support client
//8. support post
//9. client post-livraison
//10. client post livraison
//11. support
//12. livraison
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)