const regex = /\b(support post-livraison|support post livraison|support client post livraison|support client post-livraison|post-livraison|post livraison|support client|support post|client post-livraison|client post livraison|support|livraison)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(support post-livraison|support post livraison|support client post livraison|support client post-livraison|post-livraison|post livraison|support client|support post|client post-livraison|client post livraison|support|livraison)\\b', 'gm')
const str = `//1. support post-livraison
//2. support post livraison
//3. support client post livraison
//4. support client post-livraison
//5. post-livraison
//6. post livraison
//7. support client
//8. support post
//9. client post-livraison
//10. client post livraison
//11. support
//12. livraison`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}