import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(support post-livraison|support post livraison|support client post livraison|support client post-livraison|post-livraison|post livraison|support client|support post|client post-livraison|client post livraison|support|livraison)\\b";
final String string = "//1. support post-livraison\n"
+ " //2. support post livraison\n"
+ " //3. support client post livraison\n"
+ " //4. support client post-livraison\n"
+ " //5. post-livraison\n"
+ " //6. post livraison\n"
+ " //7. support client\n"
+ " //8. support post\n"
+ " //9. client post-livraison\n"
+ " //10. client post livraison\n"
+ " //11. support\n"
+ " //12. livraison";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}