import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\<li\\>\\<a target.+?\\>)(.+)(\\<\\/a\\>\\<\\/li\\>)";
final String string = "Функция Blue\n"
+ "Функция ChrW [VBA]\n"
+ "Функция CreateUnoDialog\n"
+ "Функция CurDir\n"
+ "Функция Дата\n"
+ "Функция DateSerial\n"
+ "Функция DateValue\n"
+ "Функция Day\n"
+ "Функция DDB [VBA]\n"
+ "Функция Dir\n"
+ "Функция Eof\n"
+ "Функции обработки ошибок\n"
+ "Функция FileAttr\n"
+ "Функция FileDateTime\n"
+ "Функция FileExists\n"
+ "Функция FileLen\n"
+ "Функция FormatDateTime [VBA]\n"
+ "Функция FormatNumber [VBA]\n"
+ "Функция FreeFile\n"
+ "Функция FV [VBA]\n"
+ "Функция GetAttr\n"
+ "Функция Green\n"
+ "Функция InStrRev [VBA]\n"
+ "Функция Input [VBA]\n"
+ "Функция InputBox\n"
+ "Функция IPmt [VBA]\n"
+ "Функция IRR [VBA]\n"
+ "Функция Loc\n"
+ "Функция Lof\n"
+ "Функция MIRR [VBA]\n"
+ "Функция Month\n"
+ "Функция MonthName [VBA]\n"
+ "Функция NPer [VBA]\n"
+ "Функция NPV [VBA]\n"
+ "Числовые функции\n"
+ "Функция Pmt [VBA]\n"
+ "Функция PPmt [VBA]\n"
+ "Функция PV [VBA]\n"
+ "Функция QBColor\n"
+ "Функция Rate [VBA]\n"
+ "Функция Red\n"
+ "Функция RGB\n"
+ "Функция RGB [VBA]\n"
+ "Функция Round [VBA]\n"
+ "Функция Seek\n"
+ "Функция SLN [VBA]\n"
+ "Функция StrConv [VBA]\n"
+ "Функция StrReverse [VBA]\n"
+ "Функция SYD [VBA]\n"
+ "Функция WeekDay\n"
+ "Функция WeekdayName [VBA]";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}