re = /^\s+|\s+$/m
str = ' [macro param=value pos=[0,100]][macro param=value pos=[0,100]] '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end