package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+|\s+$`)
var str = ` [macro param=value pos=[0,100]][macro param=value pos=[0,100]] `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}