$re = '/^\s+|\s+$/m';
$str = ' [macro param=value pos=[0,100]][macro param=value pos=[0,100]] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);