use strict;
my $str = '<p title="caca"></p>
<p> </p>
<b>
</b>
<B>title=" gdd "</B>
<i title="caca">dsfgjdgfs</i>
<i title=" boudin ">dsfgjdgfs</i>
<i> </i>
<i> </i>
<strong></strong>
<i style="color: orange"></i>
<a href="#"> bizurot </a> !probleme
<o: class="ms-crap"></o>
<a href="#" title=" kameleo " > test </a> !probleme <a href="#"> cramoute </a> !probleme
<a href="#" title=" banane " > test <strong>hello</strong> asaidali </a><a href="#"> hdsfahsdgf </a> !probleme </br>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>';
my $regex = qr/(?=<[^<]*[\s]+title="([^"]*)")|<\s*a\s+[^<]*>([^<]*)([^<]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}