using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=<[^<]*[\s]+title=""([^""]*)"")|<\s*a\s+[^<]*>([^<]*)([^<]*)";
string input = @"<p title=""caca""></p>
<p> </p>
<b>
</b>
<B>title="" gdd ""</B>
<i title=""caca"">dsfgjdgfs</i>
<i title="" boudin "">dsfgjdgfs</i>
<i> </i>
<i> </i>
<strong></strong>
<i style=""color: orange""></i>
<a href=""#""> bizurot </a> !probleme
<o: class=""ms-crap""></o>
<a href=""#"" title="" kameleo "" > test </a> !probleme <a href=""#""> cramoute </a> !probleme
<a href=""#"" title="" banane "" > test <strong>hello</strong> asaidali </a><a href=""#""> hdsfahsdgf </a> !probleme </br>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}