#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=<[^<]*[\s]+title="([^"]*)")|<\s*a\s+[^<]*>([^<]*)([^<]*)"
Local $sString = "<p title="caca"></p>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<b>" & @CRLF & _
" " & @CRLF & _
" </b> " & @CRLF & _
"<B>title=" gdd "</B>" & @CRLF & _
"<i title="caca">dsfgjdgfs</i>" & @CRLF & _
"<i title=" boudin ">dsfgjdgfs</i>" & @CRLF & _
"<i> </i>" & @CRLF & _
"<i> </i>" & @CRLF & _
"<strong></strong>" & @CRLF & _
"<i style="color: orange"></i>" & @CRLF & _
"<a href="#"> bizurot </a> !probleme " & @CRLF & _
"<o: class="ms-crap"></o>" & @CRLF & _
"<a href="#" title=" kameleo " > test </a> !probleme <a href="#"> cramoute </a> !probleme " & @CRLF & _
"" & @CRLF & _
"<a href="#" title=" banane " > test <strong>hello</strong> asaidali </a><a href="#"> hdsfahsdgf </a> !probleme </br>" & @CRLF & _
"" & @CRLF & _
"<p>Not empty</p>" & @CRLF & _
"<p>Not " & @CRLF & _
" empty</p>" & @CRLF & _
"<i> " & @CRLF & _
"" & @CRLF & _
" </i>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")