$re = '/^[A-Z\d]{5}-[A-Z\d]{5}-[A-Z\d]{5}$/';
$str = 'SAFEW-213SD-123SD';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);