using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z\d]{5}-[A-Z\d]{5}-[A-Z\d]{5}$";
string input = @"SAFEW-213SD-123SD";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}