const regex = /^[A-Z\d]{5}-[A-Z\d]{5}-[A-Z\d]{5}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z\\d]{5}-[A-Z\\d]{5}-[A-Z\\d]{5}$', '')
const str = `SAFEW-213SD-123SD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}