const regex = new RegExp('^(((\\d{3}[1-9]|\\d{2}[1-9]\\d|\\d[1-9]\\d{2}|[1-9]\\d{3})(\\/)(((0[13578]|1[02])(\\/)(0[1-9]|[12]\\d|3[01]))|((0[469]|11)(\\/)(0[1-9]|[12]\\d|30))|(02(\\/)(0[1-9]|[1]\\d|2[0-8]))))|(((\\d{2})(0[48]|[2468][048]|[13579][26])|((0[48]|[2468][048]|[3579][26])00))(\\/)02(\\/)29))$', 'gm')
const str = `2021/08/25
2021/09/30
2018/02/28
2024/02/29
2023/02/29`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}