import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\d{3}[1-9]|\\d{2}[1-9]\\d|\\d[1-9]\\d{2}|[1-9]\\d{3})(\\/)(((0[13578]|1[02])(\\/)(0[1-9]|[12]\\d|3[01]))|((0[469]|11)(\\/)(0[1-9]|[12]\\d|30))|(02(\\/)(0[1-9]|[1]\\d|2[0-8]))))|(((\\d{2})(0[48]|[2468][048]|[13579][26])|((0[48]|[2468][048]|[3579][26])00))(\\/)02(\\/)29))$";
final String string = "2021/08/25\n"
+ "2021/09/30\n"
+ "2018/02/28\n"
+ "2024/02/29\n"
+ "2023/02/29";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}