// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img.*?src="([^"]*)".*?width="([^"]*).*?height="([^"]*).*?>"#).unwrap();
let string = "<img src=\"http://images.efollett.com/books/978/047/012/9780470129296.gif\" width=\"80\" height=\"100\" alt=\"Organic Chemistry I (as Second Language)\" />";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}