re = /<img.*?src="([^"]*)".*?width="([^"]*).*?height="([^"]*).*?>/
str = '<img src="http://images.efollett.com/books/978/047/012/9780470129296.gif" width="80" height="100" alt="Organic Chemistry I (as Second Language)" />'
# Print the match result
str.match(re) do |match|
puts match.to_s
end