package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img.*?src="([^"]*)".*?width="([^"]*).*?height="([^"]*).*?>`)
var str = `<img src="http://images.efollett.com/books/978/047/012/9780470129296.gif" width="80" height="100" alt="Organic Chemistry I (as Second Language)" />`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}