// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)#([^\"|'][\S]+)|#[\"]{1}([^"]+)[\"]{1}|#[\']{1}([^']+)[\']{1}"#).unwrap();
let string = "Ñ‚Ð²Ð¾Ñ #погода1 ÐºÐ°ÐºÐ°Ñ Ð¿Ñ€ÐµÐºÑ€Ð°ÑÐ½Ð°Ñ #погода1 или же нет #\"хорошей погоды\" завтра #погода1 как вÑегда #хорошей погоды и Ñ Ð¿Ð¾Ð¼Ð¾Ñ‰ÑŒÑŽ #'золотого днÑ' ÑегоднÑ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}