package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)#([^\"|'][\S]+)|#[\"]{1}([^"]+)[\"]{1}|#[\']{1}([^']+)[\']{1}`)
var str = `Ñ‚Ð²Ð¾Ñ #погода1 ÐºÐ°ÐºÐ°Ñ Ð¿Ñ€ÐµÐºÑ€Ð°ÑÐ½Ð°Ñ #погода1 или же нет #"хорошей погоды" завтра #погода1 как вÑегда #хорошей погоды и Ñ Ð¿Ð¾Ð¼Ð¾Ñ‰ÑŒÑŽ #'золотого днÑ' ÑегоднÑ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}