#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)#([^\"|'][\S]+)|#[\"]{1}([^"]+)[\"]{1}|#[\']{1}([^']+)[\']{1}"
Local $sString = "Ñ‚Ð²Ð¾Ñ #погода1 ÐºÐ°ÐºÐ°Ñ Ð¿Ñ€ÐµÐºÑ€Ð°ÑÐ½Ð°Ñ #погода1 или же нет #"хорошей погоды" завтра #погода1 как вÑегда #хорошей погоды и Ñ Ð¿Ð¾Ð¼Ð¾Ñ‰ÑŒÑŽ #'золотого днÑ' ÑегоднÑ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")