re = /string ([0-9]+)/i
str = 'et more random textra ra rastring 654321hey hey my my'
# Print the match result
str.match(re) do |match|
puts match.to_s
end