using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"string ([0-9]+)";
string input = @"et more random textra ra rastring 654321hey hey my my";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}