$re = '/string ([0-9]+)/i';
$str = 'et more random textra ra rastring 654321hey hey my my';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);