// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ticky: (INFO|ERROR)(: [\w\W $]+?)(\([\w]*\))").unwrap();
let string = "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)
May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)
May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)
May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (coleman)
May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)
May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)
Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)
Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)
Jun 1 11:06:48 ubuntu.local ticky: ERROR: The ticket was modified while updating (ldelfino)
Jun 1 11:06:48 ubuntu.local ticky: ERROR: The ticket was modified while updating (ldelfino)
Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)
Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)
Jun 1 11:06:48 ubuntu.local ticky: ERROR: Tried to add information to a closed ticket (ldelfino)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}