import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ticky: (INFO|ERROR)(: [\\w\\W $]+?)(\\([\\w]*\\))";
final String string = "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)\n"
+ "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)\n"
+ "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)\n"
+ "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (coleman)\n"
+ "May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)\n"
+ "May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)\n"
+ "Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)\n"
+ "Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)\n"
+ "Jun 1 11:06:48 ubuntu.local ticky: ERROR: The ticket was modified while updating (ldelfino)\n"
+ "Jun 1 11:06:48 ubuntu.local ticky: ERROR: The ticket was modified while updating (ldelfino)\n"
+ "Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)\n"
+ "Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)\n"
+ "Jun 1 11:06:48 ubuntu.local ticky: ERROR: Tried to add information to a closed ticket (ldelfino)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}