#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ticky: (INFO|ERROR)(: [\w\W $]+?)(\([\w]*\))"
Local $sString = "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (coleman)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (coleman)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)" & @CRLF & _
"May 27 11:45:40 ubuntu.local ticky: ERROR: Created ticket [#1234] (ldelfino)" & @CRLF & _
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)" & @CRLF & _
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)" & @CRLF & _
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: The ticket was modified while updating (ldelfino)" & @CRLF & _
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: The ticket was modified while updating (ldelfino)" & @CRLF & _
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)" & @CRLF & _
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Connection to DB failed (ldelfino)" & @CRLF & _
"Jun 1 11:06:48 ubuntu.local ticky: ERROR: Tried to add information to a closed ticket (ldelfino)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")